Press "Enter" to skip to content

Pokémon Unite is updated: Spanish translation, new battle pass, Holoatuit and more

The Pokémon Company and TiMi Studios have launched a new update for Pokémon Unite on Nintendo Switch, iOS and Android. The game, which opens today Wednesday September 22 on mobile phones, it also launches a new version with significant news; one of them, the much demanded update of the game to new languages, including the Spanish of Spain. Let’s know all the news.

It may interest you:

  • Pokémon Unite: how to download for free on Android and iOS mobiles; Now available
  • Pokémon Unite: Complete Guide to Cheats, Tips, Builds and More

All the news of the Pokémon Unite update

“Since the launch of Pokémon Unite on Nintendo Switch, the team has enjoyed reading all the experiences our players have had during their adventures on Aeos Island,” the statement begins, where they acknowledge having learned a lot; and take the opportunity to promise more news in tune with the demands of the community in the coming dates. These are the news and changes added.

  • Cross-platform gaming and account linking available between Nintendo Switch and mobile devices; or vice versa. We can play with the same account on all platforms.
  • New events in Pokémon Unite with which you improve on Super Items that can go up to level 30.
  • New equippable items to facilitate new strategies.
  • Unite Squads available to play with friends.
  • Second Battle Pass with new special Holoatits, like Gengar’s.
  • New spectator mode, still in testing and limited in nature.
  • New languages ​​available: Spanish, German, French, Italian, Japanese, Korean, Simplified Chinese and Traditional Chinese; in addition to English.
  • There will be a game mode coming soon where all players will start with the same level of equipped items.

Pokémon Unite It is now available on iOS, Android and Nintendo Switch. You can check all the news of the game here. To run it on iOS terminals, it is necessary to have the mobile or tablet updated to iOS 10.0 or higher. Android 4.4 or higher will suffice; although it depends on the device.

Source | Pokémon Unite

.

Article Source

Disclaimer: This article is generated from the feed and not edited by our team.